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[springs]

Introduction

In this tutorial we will create an animated spring by using a helix shape (spline) as the path to loft a circle along. The tutorial will then show you how to link and aim the spring between 2 Dummy objects. You will then write an Expression to modify the height of the spring by calculating the distance between the 2 Dummy objects. 

 >> play the movie : spring_teaser01.mov

The objective of this tutorial is to cover additional tools for modeling and animating objects. The tutorial will also introduce you to writing simple Expressions to control an objects property and identify the problems of using Expressions in a hierarchical model.

The steps involved in the tutorial are: 

· Create the spring using a Loft

· Linking the spring and aiming it at a Dummy object

· Writing an Expression to Calculate the length of the spring

· Linking the spring to a Hierarchy

· Animating the Spring

Create the SPRING using a Loft

Create the model of the Spring by lofting a circle shape (profile) along a helix shape (path).

Points to notice here :

· The helix shape controls the path of the SPRING. 

· The height of the helix actually does matter as we will write an Expression later to modify the height of the helix according the distance between 2 Dummy objects.

[1] Reset MAX.

File > Reset

Time Configuration > PAL > Length = 100

[2] Create Helix shape in the TOP viewport.

Create Panel > Shapes > Splines > Helix 
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Note : Top viewport, Top viewport..!!

[3] Modify the properties of the Helix so that it has 5 turns and the top and bottom radius are the same. Follow the values in diagram below and notice the effect each value has on the model as you adjust it.  


Modify Panel > Helix
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[4] Create a Circle shape in the FRONT viewport for the profile of the SPRING. Follow the values in diagram below.

Create Panel > Shapes > Splines > Circle 
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Note : Front viewport, Front viewport..!!
[5] Select the Helix Shape (path) and create the spring by Lofting the Circle shape along the path. Follow the values in diagram below.

Select Helix01

Create Panel > Geometry > Compound Objects > Loft

Get Shape > Select Circle01

Rename the SPRING object – spring01
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We are now finished. Your model should look like the diagram on the right.

Save your MAX file as : 


spring01.max
Linking the SPRING and Aiming it 

The objective is to stretch the spring between 2 Dummy objects and just animated the Dummy objects. The spring will be hierarchically linked at one end to Dummy01 and aimed at Dummy02 using the LookAt Constraint.

[1] Create 2 Dummy objects and position them either side of the spring01, allowing sufficient distance for spring01 to be stretched across. It’s a good idea not to make the Dummy objects too small – we’ll need to select them later.


Create > Helpers > Standard > Dummy
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[2] The object spring01 will ultimately be aimed at Dummy02 by rotating it around it’s Pivot Point. As the Helix was created in the TOP viewport, the Pivot Point is at the bottom of the object. Reposition spring01 by Aligning the Pivot Point of the spring01 to the Pivot Point of Dummy01.


spring01 > Alignment > Dummy01  > [X Y Z Axis : Pivot Point : Pivot Point]
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[3] Link spring01 to Dummy01 
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Check the objects are linked correctly by moving Dummy01 – spring01 should also move. Remember to Undo when we’ve finished checking.

[4] Now make the spring01 aim at Dummy02 by using a LookAt Constraint. For an object to be aimed at another object (to look at it) we need to control it’s rotational values. Select spring01 and carefully follow that steps below…

Motion Panel > Rotation > Assign Controller > LookAt Constraint
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Nothing will happen – We now need to assign the target object to define which object to look at (Dummy02).

Note : For further detailed explanation on the LookAt Constraint, refer to the Robotic Arm tutorial
[5] Assign Dummy02 as the target object and make sure spring01 is aimed along the correct axis at Dummy02 (Z axis).

LookAt Constraint > Add LookAt Target > Select Dummy02 (carefully)

Select LookAt Axis > Z

Add LookAt Target > OFF
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Note : Remember to turn the Add LookAt Target OFF
Writing an Expression to Calculate the Height of the Helix

The most important concept to understand here is that we will not be animating spring01. The length of spring01 is control by the height of Helix01. 

The height of the helix will be controlled by writing an Expression to calculate the distance between Dummy01 and Dummy02. 
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[1] Open the Curve Editor for Helix01.


Select Helix01 > Right-Click > Curve Editor

[2] Open the Objects listing in the Curve Editor and navigate to the Height property of the Helix01.


Objects > Helix01 > Properties > Height
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[3] Assign a Float Expression to control the Height of the Helix.


Helix01 > Height > Right-Click > Assign Controller > Float Expression
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Before proceeding with writing the Expression Controller, it is important to understand some important basic concepts.

A Variable is simply a piece of computer memory, where information is stored under a given name. The information stored in the memory can be modified, hence the term Variable.

In the example below, the Variable distance is created and assigned the numerical value 10.

distance=10

The Expression Controller allows you to assign a mathematical value to a specific property of an object. In the Rollercoaster tutorial the cars are spread out and positioned along the path by controlling the percentage along the path relative to the first car (eg. carpos01 – 0.05).

In the Rollercoaster tutorial, the percentage a car is along the path was represented as a single number. This type of single number is also referred to as a Scalar value. This simply means that the value is represented by 1 number. The numbers 19, 5.2 and 121.01 are three examples of Scalar values.

If the three values above represented the X, Y, and Z position of an object, they could be compounded into a single Vector value. 

Therefore, to write an Expression Controller to calculate the distance between Dummy01 and Dummy02, we will need to create 2 Vector Variables and assign them the X,Y,Z position of the Dummy01 and Dummy02.

[4] Create a Vector type variable called dum01 and assign the XYZ position of Dummy01 to the variable.


Create Variables > Name > dum01 > Vector > Create


Assign to Controller > Objects > Dummy01 > Transform > Position XYZ
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[5] Create a Vector type variable called dum02 and assign the XYZ position of Dummy02 to the variable.


Create Variables > Name > dum02 > Vector > Create


Assign to Controller > Objects > Dummy02 > Transform > Position XYZ

[6] We now have the positions of Dummy01 and Dummy02 stored in the variables dum01 and dum02. Our next task is write a mathematical Expression using a function to calculate the length between to 2 points.

The mathematical functions available are listed under the Function List. However, this list is only for reference purposes. Take a look at the functions available. The function we shall use is length().
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[7] Close the Function List. The distance between Dummy02 and Dummy01 can be calculated as length(dum02-dum01). Enter the Expression as displayed in the diagram below and Evaluate the Expression to check for any possible errors and update the height of Helix01. 


Expression > length(dum02-dum01)

If the Expression is correct, the height of spring01 will now be the distance from Dummy01 to Dummy02. Check the viewports. 
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[8] We are now finished writing the Expression. Close the Expression Controller and the Curve Editor window. Our model should look like the diagram above. Check your model by moving Dummy02 about in the viewport. If everything is correct, spring01 should remain the length of the distance between Dummy01 and Dummy02. It should also always aim towards Dummy02.

Save your MAX file as : spring01.max
Linking spring01 to a Hierarchy

Unfortunately, linking spring01 to a hierarchical model is not straight forward at all. In the second part of this tutorial we will build a simple piston (similar to a pinball machine) and link Dummy01, Dummy02 and spring01 to the piston. 

When we do this we will discover the Expression Controller we wrote on the previous page no longer works. Our task in this section of the tutorial is to solve this problem.

Please remember to name the objects according to the diagram below.
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[1] Create 3 ChamferCylinders. These will be used to model the handle(cyl01), stopper(cyl02) and striker(cyl03). Follow the values in the diagram on the right.


Create Panel > Extended Primitives > ChamferCyl
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[2] Create a Cylinder. These will be used to model the connecting rod(rod01). Follow the values in the diagram on the right.


Create Panel > Objects > Standard Primitives > Cylinder

[4] Create Dummy03. This will be the Parent object in the hierarchy. Make sure Dummy03 is large, so it’s easy to select.

[5] Check the objects are correctly named according to the diagram below.
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[6] Link the objects together as a hierarchy as displayed in the diagram below. Also, remember that spring01 has already been linked to Dummy01.

Look very carefully at the hierarchy diagram below and the model diagram above. You should notice that by moving cyl01 - rod(rod01), striker(cyl03), and Dummy02 should also move.     
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According to the Expression Controller we wrote earlier spring01 should therefore squash and stretch as you move cyl01 left and right…. ….but it doesn’t..!! It’s all gone horribly wrong.
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[7] The problem with spring01 is that the position of Dummy01 and Dummy02 is no longer relative to the global axis. 

Instead, the position of Dummy01 and Dummy02 are now relative to Pivot Point of the object they are linked to in the Hierarchy. 

This problem is easily solved. 

We will create 2 Point Helper Objects, then link spring01 to one point object and aim it at the other point object. 

Instead of Linking the Point objects to the Hierarchy, we will use a Position Constraint to make sure they are constrained to the position of Dummy01 and Dummy02. The point objects and spring01 will therefore NOT be linked to the hierarchy any longer. 

[8] Create 2 Point Helper objects in the Top viewport.


Create > Helpers > Standard > Point

Name the Point objects : point01 and point02
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Disclaimer : The following steps can be achieved in a number of ways, namely by aligning the point objects to the Dummy objects and then linking. However, I have decided to do it this way so that you see what is happening and the objects are easier for you select.

[9] Move spring01 to point01 and link it. Notice it still has a LookAt Constraint to aim towards Dummy02.
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[10] Re-assign the LookAt Constraint (delete Dummy02) so spring01 is aimed at point02.

Motion Panel > LookAt Constraint > Add LookAt Target > Select point02 (carefully)
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[11] Now assign a Position Constraint to point01 so that remains in the same position as Dummy01.


Motion Panel > Assign Controller > Position > Position Constraint
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[12] Assign Dummy01 as the Position Target. 


Motion Panel > Position Constraint > Add Position Target > Select Dummy01(carefully)
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[13] Do the same for point02 so that it’s position is constrained to Dummy02.


Motion Panel > Assign Controller > Position > Position Constraint

[14] Assign Dummy02 as the Position Target. 


Motion Panel > Position Constraint > Add Position Target > Select Dummy02(carefully)

[image: image31.png]e

spiing01
Selecton Level:

Sub bt |—;|

Parameters | Trajectories

Postion: Posior,_|
™ g]Fotaton: LookAl

[ Lookatweik

§ VeclorLengh
[ Sedle - Beer S

PRS Paranelers

Create Key— [~ Delete Key—|

Posiion Posiion

Fotation Fatatio

Roldion _Scale

LookAl Consiaint

‘Add LookAl Target
Delete Laoket Target
Torget Weight —|
Poini02





[15] We now need to re-write the Expression Controller for the Helix01. This is because it was previously written to calculate the distance between Dummy01 and Dummy02.

Access the Expression Controller for the Height of Helix01 and modify it to calculate the distance between point01 and point02.


Select Helix01 > Right-Click > Curve Editor

[16] Open the Objects listing in the Curve Editor and navigate to the Height property of the Helix as displayed in the diagram below.


Objects > Helix01 > Properties > Height

Open the Controller we wrote previously by selecting properties. 
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[17] The Variables are already created, but they are currently assigned to the position of Dummy01 and Dummy02. Reassign dum01 to contain the Position value of point01.


Select dum01 > Assign to Controller > Point01 > Position
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[18] Reassign dum02 to contain the Position value of point02.


Select dum02 > Assign to Controller > Point02 > Position

Click Evaluate to check for errors and recalculate the distance between point01 and point02. Check the viewports – spring01 should now be stretched between point01 and point02.
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Check that all the objects are linked correctly and the Expression and Controllers are properly assigned. Try moving and rotating Dummy03. Then move cyl01 as though the handle is being pulled back. So long as point01 and point02 do NOT cross each other, spring01 should squash and stretch correctly.
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Animating the Spring

[1] Now you’re ready to Render a test animation of your spring…    Take a look at the diagram below – the animation shows the handle being pulled back slowly for 50 frames (2 seconds). It then pauses for 10 frames and finally is released, shooting back to the starting position in just 4 frames. 

Remember that you only need to animate cyl01. 


Auto Key > ON


It’s a good idea to open the Curve Editor for cyl01 and adjust the timing to get the SNAP effect of the spring shooting back.

[2] Render your animation as a QuickTime Movie.


Render > Active Time Segment 


Output Size > 320 * 240


Save File > Checkbox > ON 


Save File Type > MOV QuickTime > Compression > Sorenson Video 3 > Quality > High

Challenge

We’ve just created a very cool self-contained spring system. The reason it’s cool is that you only need to animate Dummy03 and cyl01 – the spring object takes care of itself. 

>> play the movie : spring_teaser02.mov

In this teaser movie I’ve simply rotated Dummy03 so that the spring system is standing up. I then start by keyframing Dummy03 to jump up and down and then keyframe cyl01 afterwards…     …the challenge here is the timing. 

Try it out for yourself, but before you start, decide what kind of tension you want in the spring. Is it a loose, light-weight spring that flops up and down?? ….or is it a tough, heavy duty spring??  …You should also consider the weight of cyl01. The combination of the material the spring is made from and weight on the end of the spring should dictate the timing of your jumping spring. 

It will help to characterise the jumping spring. If the jumping spring had the personality of a 3 year old toddle, how would it move?  …..shorter, faster jumps maybe?  ..would the spring be more fluid and less ridged?     ..How about if the spring were a 40 year old, over weight man? 
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