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[robotic arm]

Introduction

In this tutorial you will create a jointed robotic arm, which has hydraulic pistons, cables is rigged with an IK (Inverse Kinematics) chain. 

 >> play the movie : robotic_arm_teaser01.mov

The objective of this tutorial is to cover additional tools for modifying Shapes and Polygons. It will also introduce you to hierarchical modeling, the LookAt Constraint and IK Solvers. 

The steps involved in the tutorial are: 

· Create a simple jointed hierarchical arm

· Create the hydraulic pistons

· Apply a LookAt Constraint to the hydraulic pistons

· Apply a HI IK Solver (History Independent Inverse Kinematics)

· Create a Hose object for the Hydraulics

· Create a Claw
Features covered in this tutorial

In this tutorial you will learn:

· ChamferBox

· Convert to Editable Poly
· Display Edged Face
· Extrude Polygon

· Bevel Polygon

· Assign Material to Object

· Show Map in Viewport
· Look At Constraints
· Hide/Show Object
· IK Solver
· Hose
· Hierarchy
· Adjust Pivot Point
· Gimbal Lock
Create the Arm
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[1] Reset MAX.

File > Reset

Time Configuration > Frame Rate=PAL > Length=500

[2] Create 3 separate materials in the Material editor - Blue, Red and Orange. These Materials will be applied to the objects you create during this tutorial. This will make it easier to identify areas of the model and for you to spot any mistakes as you complete this tutorial. 


Material Editor > M Key
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You will start this tutorial by modeling the robotic arm. It is made from the set primitive objects below.    …A single limb of the robotic arm is created from a Cylinder and the joint is created from 3 ChamferCylinders and the pivot is created from a Capsule.

Take a look at the image on the right to familiarise yourself with the Primitive Objects you will be using.
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[1] Create a Cylinder for the arm in the TOP viewport, using the values in the diagram below.


Create Panel > Objects > Standard Primitives > Cylinder
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[2] Once you’ve create the Cylinder, adjust your viewport so you have enough room to comfortably create the next objects. 


Zoom Extents All Viewports > [image: image4.png]


 Magnifier
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[3] Create a ChamferCylinder. This will be used to model the joint. Follow the values in the diagram on the right.

Create Panel > Extended Primitives > ChamferCyl

[4] Create a second, larger ChamferCylinder for the middle section of the joint. Follow the values in the diagram below.

Create Panel > Extended Primitives > ChamferCyl
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Note : Top viewport, Top viewport..!!
[5] Apply the Blue Material to the 3 objects you’ve created. 


Select the Objects > M Key > [image: image6.png]
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Blue Material
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[4] Create the pivot object for the joint using a Capsule. Follow the values in the diagram right.

Create Panel > Extended Primitives > Capsule

[5] Apply the Red Material to the Capsule. 


Select the Objects > M Key > [image: image8.png]
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Red Material

Note : Top viewport, Top viewport..!!
[6] Adjust the viewports so that you can see all 4 objects you just created and name each object exactly as labeled in the diagram below.

Zoom Extents All Viewports > [image: image10.png]


 Magnifier
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Note : I will be referring to these objects by their specific names during this tutorial, so you are advised to follow the naming convention. 
[7] Rotate the 2 ChamferBoxes and Capsule by 90˚ as displayed in the diagram below, so they ready to be positioned as our first jointed arm. 

Select Object > Angle Snap > ON [image: image11.png]


 > rotate 90˚
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[8] Position joint_end01, joint01 and pin01 relative to rod01 to create the arm. Take a look at the diagram on the next page for reference. Start by aligning joint01 to the bottom and centre of rod01. 

To use the Alignment tool you must select the object you wish to align, then the Alignment button and finally the target object you wish to align to. In this case you wish to align the center of joint01 to the center of rod01 along the X axis. 

joint01 > Alignment > rod01  > [X Axis : Center : Center]

[image: image66.png]




[9] Now, using the same process, align joint_end01 and pin01. Follow the steps below for each object. 

join01 > Alignment > rod01 > [Y Axis : Pivot Point : Point]

joint01 > Alignment > rod01 > [Z Axis : Center : Center]

joint_end01 > Alignment > joint01 > [XYZ Axis : Center : Center]

joint_end01 > Alignment > joint01 > [X Axis : Min : Max]

pin01 > Alignment > joint01 > [XYZ Axis : Center : Center]

Note : it’s easy to make a mistake here, so take a look at the diagram below to see what you’re trying to achieve.
[10] Copy joint_end01 and move it to the left of rod01. Name the new object joint_end02 and align it.

joint_end01 > [image: image13.png]


 + SHIFT (copy and move)

joint_end01 > rename it > joint_end02
joint_end02 > Alignment > joint01  [X Axis : Max : Min]

Check all the alignments. Your models should now look like the diagram below. Make sure you check all the viewports. Your next task is to link them together. 

[image: image14.png]



[11] In previous tutorials you have learned to joint objects together using Attach. This actually fuses the objects together into 1 object. Attach is great if your objective is to create  single object with a single pivot point and have a single Material assign to it. In this tutorial we want to keep all the parts separate so that you can assign Materials to separate objects later. 

To join the objects so that move together, but are still separate objects we will create a Hierarchy. This means that objects are linked to together. The objects being linked are called child objects. The object you link to is called the parent object.

Look at your arm. The upper arm (above the elbow) is the parent object. The lower arm (below the elbow) is the child object. If you rotate your upper arm, the lower arm follows. However, the lower arm can still rotate independently if needed. The same goes for your hand. Your hand is a child object linked to your lower arm. 

The important thing to notice here is the position of the pivot point. The pivot point for the upper arm is at the shoulder. For the lower arm it’s at the elbow and for the hand it’s at the wrist. 

For this tutorial, the pivot point for each section of the robotic arm should be in the centre of the pin object (red capsule). Take a look at the diagram on the previous page to familiarise yourself with this concept. 

OK, now that you understand the concepts, you’ll need to link the objects together. As you made the cylinder for rod01 in the TOP viewport, the local axis (pivot point) is at the bottom. We could link all object for the arm to pin01 (red capsule). However, we need to work smart here..   … pin01 is a small object that is obscured by other objects – it will be frustrating to select it in future when we need to animate it. So, what you will do in link pin01, joint_end01, joint_end02 and joint01 to rod01. This will create a hierarchy where rod01 is the parent object. 


Select pin01, joint_end01, joint_end02 (click+ Ctrl) > link  [image: image15.png]


 > rod01
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As you link the selected objects to the parent object you will see a dotted white line indicating which objects are linked to which target.

When you release the mouse button, all the objects you have just linked will flash white just once. 

If you have linked the objects incorrectly, just select the objects again and link them to the correct object. 

You can check if the hierarchy is linked correctly simply by moving rod01. If all the object follow (appear to be joined), then it’s correct. If not, try again.

Remember to Undo the Move once you have checked the hierarchy. 

[12] The first section of the arm is finished. You now need to create the second section. There is no need to repeat the previous steps. In the Front viewport, select all the objects and Copy+Move to create the second section of the arm (see the diagram below for reference). 

Select ALL > [image: image16.png]


 + SHIFT 

[image: image68.png]&

Dummy02

Dummy01




Rename the new objects according to the diagram right.

Copy pin02, place it at the top of rod02 and rename it pin03. 

[13] Create the 2 base objects using the ChamferCyl object in the top viewport and align them.

Radius > 165.0

Height > 65.0

Fillet > 7.0

Apply the Blue Material to the base objects. 

[image: image17.png]


 Blue Material

  …..and rename them base01 and base02.

[14] Link the objects together. 

pin03 > Link > rod02

rod02 > Link > rod01


rod01 > Link > base01


base01 > Link > base02

Congratulations!!! The basic robotic arm hierarchy is now finished..!! 

Base02 is the parent object (root) of the entire model. Try moving it – the entire model should move. Rotating base01 in the Y axis (front viewport) will allow the robotic arm to rotate. Rotating rod01 and rod02 will allow you to pose the arm. Try it and make sure the arm is linked correctly. 

Remember to undo when you’re finished and be aware the MAX can only undo 20 times..!! 

[image: image69.png]


Adding the Hydraulic Pistons

The arm is slightly sad.. …it needs muscles to show it’s power. So you’ll now add a single set of hydraulic pistons between rod01 and rod02.

This method is only cover once in this tutorial, but you’re free to repeat the steps and create as many hydraulic pistons as you want later. 

There a very simple principle involved in making the Hydraulic piston. You will create 2 dummy objects and link them to the model (see diagram right). 

You will then place a large diameter cylinder at Dummy01 and get MAX to constantly aim it at Dummy02.

You will then place a smaller diameter cylinder at Dummy02 and get MAX to constantly aim it at Dummy01.

As you rotate and animate the arms, the 2 cylinders will be constantly facing each other and sliding together like a hydraulic piston.

Note : Dummy objects do not appear when you render your animation. They are used for reference purposes only.

[1] Create 2 Dummy objects and position them as displayed in the diagram right (left viewport).


Create Panel > Helpers [image: image18.png]


 > Dummy

Note : The local axis of the Dummy object is in the middle of the cube.
[2] Link the Dummy objects to the model (see diagram above). [image: image19.png]




Dummy01 > Link > rod01


Dummy02 > Link > rod02

Check the Dummy objects are linked correctly.

[3] You now need to create the 2 Hydraulic pistons parts, consisting of the piston base and piston rod. As the piston rod slides inside the piston base, you will create it using a simple cylinder.

Create a ChamferCyl in the Top viewport with the values in the diagram below and name it piston01.

Create Panel > Extended Primitives > ChamferCyl
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[4] Align piston01 to Dummy01 by their pivot points (local axis) – see diagram above.

piston01 > Alignment > Dummy01 [XYZ : Pivot Point : Pivot Point]

[image: image70.png]


[5] Create the piston rod.

Create a Cylinder in the Top viewport with the values in the diagram on the right and name it piston02.

Create Panel > Primitives > Cylinder

[6] Align piston02 to Dummy02 by their pivot points (local axis).

piston02 > Alignment > 

             Dummy02 [XYZ : Pivot Point : Pivot Point]

Apply the Orange Material to both piston objects. 

[image: image21.png]


 Orange Material
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[7] Remember that each piston object will be aimed at the opposite dummy object. Piston01 will be aimed at Dummy02 and piston02 will be aimed Dummy01.

The pistons will need adjusting later to make sure they look convincing and that they don’t intersect each other – the piston rod doesn’t go through the piston base.

Link the piston objects to their respective dummy objects, so that we only need to adjust the dummy objects later.

[image: image22.png]




piston01 > Link > Dummy01


piston02 > Link > Dummy02

Check your model is linked correctly and remember to undo any transformations (move, rotate) when you’ve finished. 

[8] Now make the piston objects point at each other using LookAt Constraint. Start by making the piston01 look at Dummy02. For an object to aimed at another object (to look at it) you need to control it’s rotation values. If I ask you to look at me, it’s your head that rotates. Select piston01 and carefully follow that steps below…

Motion Panel > Rotation > Assign Controller > LookAt Constraint
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Nothing will happen – You now need to assign the target object (tell it which object to look at). 

[9] Assign Dummy02 as the target object and make sure piston01 is aiming the correct axis at Dummy02 (Z axis).

LookAt Constraint > Add LookAt Target > Select Dummy02 (carefully)

Select LookAt Axis > Z

Add LookAt Target > OFF

[image: image24.png]



[10] Select piston02 and repeat the last 2 steps to aim it at Dummy01. 

Motion Panel > Rotation > Assign Controller > LookAt Constraint

LookAt Constraint > Add LookAt Target > Select Dummy01 (carefully)

Select LookAt Axis > Z

Add LookAt Target > OFF

Note : Remember to turn the Add LookAt Target OFF

Check your model against the diagram below. It is important to understand that the Z axis of piston02 is now facing down to LookAt Dummy01.
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Check your model by rotating rod02. Notice what happens to the piston parts. Firstly, they should always be pointing at each other, so there is no need to animated them. They are in effect an independent system. Secondly, notice that as you rotate rod01 the piston parts are sometimes too short for each other. You easily adjust this later by modifying the height value of either object.


Modify Panel > Height

But, don’t bother to do it now. This is a minor adjustment you’ll make towards the end of this tutorial which should be dependant on how you animate your robotic arm.

Currently, your robotic arm is a hierarchy. You can rotate the individual objects to form the positions you desire for each keyframe. The system is call Forward Kinematics (Forward Movement). When animating a hierarchy like this, you would normally start by rotating rod01 and then rod02 to achieve the desired pose. The values are passed forward down the hierarchy. 

There is nothing wrong with this way of animating a jointed object, but there is a another system, which makes animating a hierarchy a lot faster. This system is called Inverse Kinematics (IK). IK allows you to move the object at the end of the hierarchy (like the hand) and the limbs will follow.

Consider this..  ..when you reach for a cup, you do not calculate the rotation of your shoulder, then your elbow and finally your hand. What you do is move the end object of the hierarchy (your hand) directly towards the cup and the rotations back up the hierarchy to you shoulder are calculated instinctively.

Your robotic arm will eventually have a Claw at the end. So it might be difficult to select any small object you now place at the end of the robotic arm. To solve this you will place a Dummy object  (Dummy03) above rod02, leaving room for the Claw later. The intention is that the arm will follow the Dummy03 wherever you move it. 

Adding the IK Solver
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[1] Create a new Dummy object, name it dummy03, place it above the model (aligned to the center) and link it to rod02.

Leave enough room between the end of rod02 and Dummy03 for the robotic claw (see diagram right).

Note : Don’t forget to link to Dummy03

[2] Rotate the arm to give MAX an idea of which way the limbs can bend (see diagram below).

rod01 > rotate > -40˚

rod02 > rotate > 90˚

Notice that piston01 and piston02 are now intersecting with each other (see diagram below). You can adjust them by moving dummy01 and dummy02, but you need to change the axis system to Local. This will allow you to move them relative to their current orientation (rotation angle). 

Axis system > Local > Move [image: image26.png]



Note : remember to return the axis system to View when you have finished adjusting the dummy objects.

The basic components for the arm are now finished. 

Save the project > arm_01.max
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[3] Now add the IK Solver. Be very careful when following these steps. You can always reload arm_01.max and start these steps again. 

Here’s a quick summary of what you need to do to add IK Solver.

1. Select Dummy03.

2. Add IK HI Solver to Dummy03 (small blue cross appears)

3. Create the IK chain, by linking Dummy03 with rod01 (white dotted line)

4. Increase the display size of the IK target so it’s easy to select

5. Link the IK target to the hierarchy so that it follows any rotation we apply to base01

OK, select Dummy03 and follow the steps below.

Animation > IK Solvers > HI Solver > select rod01 

Note : In the diagram below the IK chain (white line) is displaying a chain through the pivot points. Do not make the mistake of linking the HI Solver to the joint objects. It must be linked to rod01.
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[4] Notice inside dummy03 there is a cross. This is the IK Solver Target – this what you’ll need to move to make the robotic arm animate. Increase it’s size so that it’s easy to select in future. 

Motion Panel > Goal Display > Size > 100
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[5] If base01 of the robotic arm is rotated, the IK solver will be left behind and the arm will twist painfully..!! The IK Solver needs to linked to the model so that it rotates with the whole model.

IK Solver > Link [image: image29.png]


 > base01

Congratulations..!! The IK chain for the arm are now finished. Save project arm_02.max
[6] After you have saved the file, you should check all the components are linked correctly and the IK solver is working. Your robotic arm should now be rigged in such a way that you only need to rotate base01 and move the IK Solver. 

Take a look at the diagram below and put your robotic arm through a similar physical test. Remember to Undo afterwards. 

[image: image30.jpg]



Adding a Hose

The hydraulic fluid that powers the hydraulic pistons needs a hose. You need to create a hose with both ends connected to separate Dummy objects. One Dummy object will then be linked to the piston base and the other to rod01.

[1] Create a hose and 2 new Dummy objects in the Top viewport. 
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Create Panel > Extended Primitives > Hose

Don’t worry about the values – we’ll modify them all in the next step. Just apply the Red material to the hose

[image: image31.png]


 Red Material

Create Panel > Helpers > Dummy

Rename the Dummy objects dummy04 and dummy05.
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[2] Modify the Hose to be connected (bound) at each end to the Dummy04 and Dummy05  – see the diagram below for reference. 

Modify Panel > Hose > End Point Method > Bound to Object Pivots

Top Object > select Dummy04

Pick Bottom Object > select Dummy05

Modify the Hose to be a single ridged hose instead of a stretchy one (feel free to try the FLEX hose options after this tutorial)

Common Hose Parameters > Flex Section > Enabled > OFF

…And finally, increase the Segments so the hose can bend nicely.

Common Hose Parameters > Segments > 20

Hose Shape > Round Hose > Diameter > 20

Notice the Hose is bound to the Z axis of the Dummy objects – it’s plugged into the top.
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[3] We obviously need the Hose to hang down naturally. Rotate both Dummy object 180
˚ so the Hose hangs below them.

Dummy04 > Rotate > Y Axis > 180˚

Dummy05 > Rotate > Y Axis > 180˚
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[4] Position Dummy04 next to rod01 and link Dummy04 to rod01. [image: image34.png]



[5] Position Dummy05 next to piston01 and link Dummy05 to piston01. [image: image35.png]



[image: image36.jpg]



Building the Hydraulic Claw

Take a good look at the diagram below. Notice that the Hydraulic Claw consists of 2 sides – which have 3 fingers and 2 fingers respectively. The pivot point for each side is in the Cylinder (red) that joins the fingers.    ..Also notice there is a Knuckle on the back of the fingers, used to connect to the Hydraulic pistons. 

It important to understand that for each side of the Claw, all objects are Linked to the Pivoting Cylinder (red). By rotating the cylinders, you’ll animate the Claw opening and closing. As the Cylinder is so small and obscured most of the time, you will ultimately connect each Cylinder to a large Dummy object to make animating easier. The 2 Dummy objects will then be connected to the top of the robotic arm – rod03. 
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The steps involved in making the Claw are straight forward – nothing new. 

· Create a ChamferCyl

· Create a ChamferBox

· Modify the ChamferBox with the Bend and Taper Modifiers

· Bevel some Polygon faces to create depression in metal

· Bevel some Polygon faces to create grips on finger tips

· Extrude some Polygon faces and Bend vertices to create the Knuckle

· Create the Knuckle Cylinder

· Make 4 copies of the finger objects

· Align them onto of each other

· Select 2 fingers and Mirror them

· Link the objects to their respective pivot point Cylinder 

· Create a Dummy object for each side of the Claw

· Link the parts to the respective Dummy object

· Link the Dummy object to rod01

[1] Create the knuckle for the first finger with a ChamferCyl. Follow the values in the diagram right.

Create Panel > Extended Primitives > ChamferCyl

[2] Apply the Blue Material to the ChamferCyl. 


Select the Objects > M Key > [image: image38.png]
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 Blue Material

Note : Top viewport, Top viewport..!!
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[3] Create the object for the first finger with a ChamferBox. Follow the values in the diagram below.

Create Panel > Extended Primitives > ChamferBox

[4] Apply the Blue Material to the ChamferBox. 


Select the Objects > M Key > [image: image40.png]



[image: image41.png]


 Blue Material

Note : Top viewport, Top viewport..!!
[image: image80.png]



[5] Align your objects as displayed in the diagram below. 

[image: image42.png]rrrrr





[6] You will need to apply the Bend, Taper and Bevel Modifiers the ChamferBox so convert the ChamferBox to an Editable Poly.


ChamferBox > Right-click > Convert To: > Convert To Editable Poly
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[7] In the Top viewport, apply a Taper Modifier to the X axis of the ChamferBox. Use the values in the diagram below.


Modifier Panel > Modifier List > Taper > Amount > -0.7


Taper Axis > Primary > X 


Taper Axis > Effect >Y
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[8] In the Top viewport, apply a Bend Modifier to the X axis of the ChamferBox. Use the values in the diagram below.


Modifier Panel > Modifier List > Bend > Angle > 45˚


Bend > Direction > 90˚


Bend Axis > X

The Bend should be a sharp bend rather than a smooth curve. Adjust the Limits of the Bend so that it only effects the center section of the ChamferBox.


Limits > Limits Effects > ON


Upper Limit > 70.0


Lower Limit > 0.0
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[9] Consolidate the Taper and Bend Modifiers by collapsing the Modifier Stack (list).


Right-Click on Modifiers > Collapse All

[10] You’ll now Bevel the 4 Polygon faces on the Finger tips to create grips. Select the ChamferBox active the Polygon Mode.


Modifier Panel > Polygon Mode > Select the 4 Polygons (Select + Control)
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[11] Bevel the Polygon faces using the values in the diagram below.


Modifier Panel > Polygon Mode > Bevel
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[12] Select the 10 Polygon faces on the back of the Finger and Bevel them twice to create the depressions in the surface of the Finger. Use the values in the diagram below.

Modifier Panel > Polygon Mode > Select the 4 Polygons (Select + Control)

Polygon Mode > OFF
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[13] Convert the ChamferCyl to an Editable Polygon so that you can Attach (fuse) the ChamferBox and ChamferCyl together to form a single new object.

ChamferCyl > Right-click > Convert To: > Convert To Editable Poly
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[14] Attach the ChamferBox to the ChamferCyl.

Select ChamferCyl > Modifier Panel > Attach [image: image47.png]aitach 0



 > Select ChamferBox

[15] Scale the finger by 60%.

Note : The model is too big..!! Scale is by 60%

[16] Select the Polygon face on the knuckle of the finger and Bevel it 4 times, using the values in the diagram below to form the knuckle appendage. Use the APPLY button to save some time.
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Next, apply a Bend Modifier to the vertices of the knuckle appendage; however, the bend will not be centered at the center of the appendage – it will be centered close to the Finger itself. You’ll need to adjust the Bend Modifier Gizmo. 

The Gizmo an object that represents the boundaries and values of influence for a Modifier. 

[17] Change the Selection Mode the Marquee and select the vertices of the knuckle appendage.
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[18] Apply a Bend Modifier to the vertices, using the values in the diagram below. Move the Gizmo closer to the finger so the Bend radiates from the Finger.


Modifier Panel > Bend > Move Gizmo
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[19] Create a ChamferCylinder. This will be used to model the joint on the end of the Knuckle Appendage. Follow the values in the diagram below.

Create Panel > Extended Primitives > ChamferCyl

[image: image49.png]il e @

Radus: [0 2]
Height [100__ 2
Filer [0 2

CopSegs [T 2
¥ Smooth
I™ Sics0n

Sice Fom: [05—— 2/

Se T [TT——





[20] Position the ChamferCyl at the end of the knuckle appendage – be careful to check the position in all viewports before you attach it.

[21] Attach the ChamferCyl to the Finger. 

Select the Finger > Modifier Panel > Attach [image: image50.png]aitach 0



 > Select ChamferBox

[22] Apply the Blue Material to the Finger. 


Select the Finger > M Key > [image: image51.png]
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 Blue Material 

[23] In the Left Viewport, create 4 copies of the Finger. 

Select Finger > [image: image53.png]


 + SHIFT (copy)

[24] Rotate and Move all 5 fingers as displayed in the diagram below. (Left Viewport)

[25] Align the Fingers so they are perfectly placed on top of each other. They should be aligned so that each Finger is placed with it’s minimum Y value on top the maximum Y value of the Finger below it. See diagram below.
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[26] Rename the Fingers from the top down : 

Finger01 – Finger05.

[27] Select Finger02 and Finger04 and Mirror them around the X Axis to create the second side of the Claw. 

There is no need to Clone the Fingers (Copy).

[28] Carefully Move the fingers and adjust them into Clasped position displayed in the diagram below. This will be considered the default position of the Claw. 

[29] Now add the details. 

· Create a single Cylinder for the connecting pin between the Knuckles.

· Create another Cylinder for the connecting pin of the wrist. 

· Create a large (easy to select) Dummy object positioned at the wrist (see image below). 

Do take you time doing this – make sure your objects are positioned very carefully. 

· Repeat the steps for the Left and Right sides of the Claw. 

· Link all the objects for the left section of the Claw to the left Dummy object.

· Link all the objects for the right section of the Claw to the right Dummy object.

· Finally, Link the 2 Dummy objects to pin03.


To animate the Robotic Arm, you only need to Move the IK Solver, Rotate pin03 and Rotate the dummy objects for the Claw.

Save project arm_03.max
We will continue in the next short tutorial with how to pick objects up and drop them. 

Check your model is Rigged properly. Take a look at these reference images to see how I’ve added some simple details and the hydraulic pistons for the Claw. 
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Challenge

Well Done!! …You’ve just created the Robotic Arm. However, this tutorial only covers each concept and procedure once. Your Challenge is to add several more Hydraulic pistons and Hoses to create a more convincing model. 

Be sure to check your model as you add these extra details – It very likely you’ll need to adjust the length of each set of pistons.

Have a look at the photo below. Notice the position of the hydraulic pistons. For maximum force, they are placed perpendicular to the object they are going to push/pull/lift. Notice the proportions of the vehicle. Everything is short and stocky. This gives the feeling the vehicle is strong and powerful. Long and slender model would not. The addition of the small figure confirms it’s monolithic size and structure. Without the figure this could simply be a Tonka Toy..!! 

Last point worth noticing is that by combining this tutorial with the conveyor belt tutorial, you have all the information necessary to build and animate this beast of a vehicle. Good Luck..!! 
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OK, maybe the Bulldozer is slightly ambitious. On a more realist note, here’s my quick attempt to change the proportions of the model and add a couple more Hydraulic pistons to make the model more appealing.
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