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[animated conveyor belt]

Introduction

In this tutorial you will create an array of 30 metal sections, that fit together to form a conveyor belt. You’ll then create a Shape for the path of the conveyor belt. 

 >> play the movie : conveyor_teaser.mov

The objective of this tutorial is to cover additional tools for modifying Shapes and Polygons. It will also introduce you the hierarchical structure of the Materials editor and allow you to create a Multi/Sub-Object Material, which includes a bitmap and a bump map. 

The steps involved in the tutorial are: 

· Create a ChamferBox for a single section of the conveyer belt

· Convert ChamferBox to Editable Polygon

· Extrude 2 faces of the ChamferBox to create a simple joint

· Assign a the Material ID 2 to top and bottom polygons of the ChamferBox

· Add UVW mapping to ChamferBox

· Create a Multi/Sub-Object Material with 2 materials

· Assign a simple diffuse colour (dark blue) for Material ID 1

· Assign a Map for Material ID 2 and adjust the tiling

· Assign a Bump Map for Material ID 2 and adjust the tiling

· Adjust the specular value to make Material ID 2 shiny

· Create an Array of 30 sections and position them in a long line

· Create a Shape for the path of the conveyor belt

· Deform the 30 sections to fit the Path of the conveyor belt

· Animate the conveyor belt

· Render the Animation 

Features covered in this tutorial

In this tutorial you will learn:

· ChamferBox

· Convert to Editable Poly
· Display Edged Face
· Extrude Polygon

· Set Material ID

· Assigning Material ID to selected Polygon

· UVW Map

· Multi/Sub-Object Material

· HSV Colour Selector

· Texture Map

· Bump Map

· Texture Tiling

· Specular Highlights

· Assign Material to Object

· Show Map in Viewport

· Array

· Line Shape

· Outline Spline

· Fillet Vertex

· Weld Vertex

· PathDeform Modifier
Create a Metal Section for the Conveyor Belt
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Create and modify a ChamferBox to model a section of the conveyor belt.

Points to notices here :

· The ChamferBox allows you to create a box with beveled edges. 

· 2 polygons have been extruded to create simple joint to the next section.

· The model has UVW mapping co-ordinates applied (orange box).

· The model has a Multi/Sub-Object  material applied to it.
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[1] Reset MAX.

File > Reset

Time Configuration > PAL > Length = 500

[2] Create ChamferBox in the TOP viewport.

Create Panel > Geometry > Extended Primitives > ChamferBox
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Note : Top viewport, Top viewport..!!
[3] Modify the properties of the ChamferBox so that it has sharp beveled edges, 5 segments in the length (allowing you to extrude 2 polygons for the joint) and 5 segments in the width (allowing the section to bend as fits around the corner of the conveyor belt). 

Follow the values in diagram below and notice the effect each value has on the model as you adjust it.  

Note : Don’t forget to uncheck the Smooth option to give the object sharp edges.
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[4] Adjust the Perspective viewport to display Smooth + Highlights and the models Edges Faces. This will allow you to select and extrude the polygon faces for the joint. 


Right-Click Perspective Viewport 

Smooth + Highlights > ON

Edged Faces > ON
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[5] Convert the model to an Editable Polygon so that you can modify it at the sub-object level (vertices, segments and polygons).


Right-Click Model > Convert To: > Editable Polygon 
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[6] Select 2 polygon faces and extrude them along the local normal (direction) by 10.0.


Modifier Panel > Polygon Mode > ON


Select 2 Polygon Faces > Extrude Dialogue Box > Local Normal >10.0

Note : Ctrl + Select = multiple selection
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Modifier Panel > Polygon Mode > OFF
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Assigning UVW Mapping Co-ordinates

You’ll need to apply Mapping co-ordinates to the model for the material to appear without any distortion. If you don’t, the material will stretch across the faces of the joint you just created above. 


Modifier Panel > Modifier Menu > UVW Mapping


Mapping Type > Box

The UVW Mapping GIZMO should appear as an orange box bounding box around the model. If it doesn’t fit tightly around the model…


UVW Mapping > Parameters > Alignment > Fit
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Assigning New Material ID

Our plan is to apply 1 material with  2 sub-materials to the model. To do this you need to assign 2 separate Material ID’s to the faces. By default, all the faces have the Material ID 1. 

Assign the Material ID 2 to all the top and bottom faces of the model – leaving all the other faces with the default Material ID 1.

[1] Select all top and bottom faces of the model.


Modifier Panel > Polygon Mode > Select
Note : Ctrl + Select = multiple selection
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[2] Assign the selected faces the Material ID 2.


Polygon Properties > Material > Set ID > 2

Modifier Panel > Polygon Mode > OFF

You will now create a material with 2 distinctly different textures. 1 sub-material (dark blue colour) will be assigned the Material ID 1 and the other sub-material (metal plate bitmap) the Material ID 2. 

This will allow your model to have 1 Material, but apply different sub-materials on certain faces.

In this tutorial we only use 2 textures for the Multi/Sub-Object Material, but in future you can use as many as you want. 

Creating Multi/Sub-Object Material

This diagram shows how the Multi/Sub-Object Material is created. After you have assigned the Material ID to the faces of your object (previous page), you can create a single material that has 2 sub-materials.  

Look carefully at this diagram and notice the Multi/Sub-Object Material is created as a hierarchy. 

Material ID 1 -> a simple dark blue colour
Material ID 2 -> a diffuse bitmap & a bump bitmap.
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[1] Open the Material Editor > M Key

Navigating within the Material Editor can be very confusing. So before you start, please take note the you can navigate UP and ACROSS a level in the hierarchy using the following buttons… 
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 Go to Parent
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 Go to Sibling

As you are creating the Material, you will want to preview it on the model in the Perspective viewport. Make sure the model is select in the Perspective viewport and assign the material to the object and show the map (material) in the viewport.
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 Assign Material to Selected Object
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 Show Material in Viewport

[2] You can now start to create your Multi/Sub-Object Material (default = Standard).


Material Type > Multi/Sub-Object
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[3] As you are go to modify the current material, 3DS MAX will ask you what you want to do with the current material values. You can select either of the radio buttons, then OK. 
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[4] The default number of sub-object materials is 10. Set the number of sub-object materials to 2.


Set Number of Material > 2

[5] In Material ID 1, add a simple dark blue colour.


Material ID 1 > Diffuse Colour > Colour Selector > Pick your colour
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Note : Notice that half of the faces of the sphere in the preview window become dark blue.

[6] In Material ID 2, add a map (jpeg bitmap) of a metal texture.


Material ID 2 > Sub-Material > Maps > Diffuse Color > Map


Material/Map Browser > Bitmap > C:\3dsmax7\maps\Metal\MtlPlat2.jpg
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Note : There is actually a reference number displayed to remind you of which Multi/Sub-Object Material you are currently editing.

In this case you are editing Material ID 2 – which is displayed as [2] : 
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[7] Increase the Tiling value of the map, so that it repeated across the width of the model.


Tiling > V > 2.0

Note : Make the sure the UV radio button is checked and the Tile check boxes are ON.

[8] Navigate back up to the top level of Material ID 2.
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 Go to Parent


[9]Add a map (jpeg bitmap) for the bumpiness (displacement) of the material and increase the bumpiness value of the material.

Material ID 2 > Sub-Material > Maps > Bump > Map


Material/Map Browser > Bitmap > C:\3dsmax7\maps\Metal\MtlPlat2_Bump.jpg


Amount > 80
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[10] Increase the Tiling value of the bump map, so that it is repeated across the width of the model.


Tiling > V > 2.0

Note : Make the sure the UV radio button is checked and the Tile check boxes are ON.

[11] Navigate back up to the top level of Material ID 2.
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 Go to Parent
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[12] The shininess of the highlights of an object is measured by the Specular Level. Increase the shininess of Material ID 2 and make the highlights tighter (smaller).


Specular Level > 80


Glossiness > 20

As we said earlier, navigating the levels within the Material Editor can be very confusing – so just incase you are having any difficulty, here are the 4 most important buttons to navigate through the Material Editor and preview your material in the viewport.

You can navigate [image: image17.png]


 UP and [image: image18.png]


 ACROSS a level in the hierarchy. 

As you are creating the Material, you will need to preview it on the model in the Perspective viewport. Make sure the model is selected in the Perspective viewport and [image: image19.png]


 assign the material to the object and [image: image20.png]


 display the material in the viewport.
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You are now finished. Close the Material Editor (M Key). Your model should look like the diagram on the right.

Save your MAX file as : 


conveyor_belt01.max

Creating an Array

[1] You now need to create an array of 30 sections.


Tools > Array

Follow the values in the diagram below. 
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Note : Make sure your array Type of Object is COPY. This will allow each of the sections to deform independently around the corners of the conveyor belt. If you don’t select COPY, the 30 sections will remain in a straight line and you will not be able to deform them.

Your model should now look like this..
[image: image22.png]



Creating the Shape for the Path of the Conveyor Belt

You need to create a Shape for the path of the conveyor belt. You will create the Shape in the FRONT viewport. Select the Front viewport and turn the Grid OFF.

Grid OFF > G Key
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You need to be able to see very clearly what you are doing in the viewport. [image: image23.png]


 Maximise the Front viewport and make sure you can see all 30 conveyor belt sections by using [image: image24.png]


 Zoom Extents. Change the Front viewport display mode to Wireframe. 

Note : Front viewport, Front viewport..!!

In order to show you more of the tools in 3DS MAX, you will create the Shape for the path (see diagram) using a single Line, which you will modify with the Outline tool to form a rectangle and then Fillet both ends. To make things even more interesting, you will not create the Line with the mouse -  you will use the Keyboard Entry.
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[1] Create a simple line, using the Keyboard Entry panel.

Create Panel > Shape > Line 

Keyboard Entry > [X=0] [Y=-500] > Add Point

Keyboard Entry > [X=1250] [Y=-500] > Add Point

Keyboard Entry > Finish

[image: image54.png]7|4 e/mT|
Y& O RS e

Rectangle

Cicke

Elipse.

A Donut
NGon Star
Text Heli

Section




Online

[1] Create an Outline of the Line.

Modifier Panel > Line > Spline Mode > ON

Outline > Center > ON > 200
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Fillet

[1] Fillet the 4 vertices to round the ends of the Shape.

Modifier Panel > Line > Vertex Mode > ON

Select all 4 vertices > Fillet > 99.0 (as high a value as possible)

Fillet > OFF
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Weld

You now have 2 vertices in the same place at each end of the shape. It is not a good idea to leave vertices touching each other as it can cause problems later. To solve this problem you can select the 2 vertices that are touching each other and Weld them together to form 1 new vertex. You will need to repeat this for both ends of the Shape. 

The Weld value represents the proximity. In this case, vertices within a proximity of 30 will be welding into 1 new vertex.

Modifier Panel > Line > Vertex > Select the 2 vertices > Weld Value=30 > Click Weld 

Repeat the step for the other end of the Shape.
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Vertex Mode > OFF

PathDeform
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[1] Deform all 30 sections of the conveyor belt to the Shape of the path using a PathDeform modifier.


Select All > Modifier Panel > Modifier List > PathDeform


Pick Path > click the Shape


Path Deform Axis > X

You will need to Stretch the conveyor belt sections so that first and last sections are touching correctly. 

Adjust the Stretch value to see the effect. Be careful - it’s very sensitive. If you have used the same values indicated in the previous pages of this tutorial, the Stretch value should be 0.895.

If you have not used the same values, you need to adjust the stretch value yourself. You are advised to Zoom in closer to the model to ensure the first and last section are really touching correctly.
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Your conveyor belt should now look like this.



Animating the Conveyor Belt

[1] Now you’re ready to animate the conveyor belt…    …You will animate it moving 100% of the length of the path, over 100 frames.


Auto Key > ON


Time Slider > slide to frame 100


Modifier Panel > PathDeform > Percent > 100


Auto Key > OFF
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[2] Play your animation. Notice that the conveyor belt automatically has a slow-in and slow-out. This means the animation begins in a static position and accelerates. It then decelerates to a total stop at the end. As our intention is to create 100 frames of animation that can be looped, this is not correct.
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[3] Right-Click on any of the 30 conveyor belt sections and open the curve editor. This allows you edit how objects translate over time between keys.

[4] Take a good look at the Curve Edit (next page). It is very powerful..    …it can make the difference between objects simply translate between keyframes and objects that truly have character, intention and weight.

Find and select the Percentage along Path controller for ChamferBox01. Notice that the 2 keyframes are indicated at each end of the curve by a small grey box. 
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[5] Change the curve to be a linear straight line, so that the conveyor belt moves constantly at the same speed.

Select Keyframes > Set Tangent > Linear

[6] Set the Animation Length to 500 frames.

Time Configuration > Frame Count > 500
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[7] Play the animation and notice that the conveyor belt stops moving after 100 frames. Loop the animation with a Linear Out-of-Range setting.


Curve Editor > Param Curve Out-of-Range Types > Click Linear IN and OUT button
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[8] Play your animation. The animation will now loop for 500 Frames.

Modifying the Model

[image: image58.jpg]


[1] Yikes!! The model sections of the conveyor belt look too narrow. You’ll need to select and scale all the sections so that they are longer and thinner – 300% longer. 

Scale > Y > 300%

Note : Open the Scale Transform Type-In dialogue box by right-clicking on the Scale button.

[2] This will cause the Material on the model sections to stretch. You can solve this problem by returning to the Materials Editor and changing the Tiling for Diffuse Map and Bump Map to 6 (see diagram below).
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Your conveyor belt should now look like this.
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[3] Render you animation as a QuickTime Movie.


Render > Active Time Segment 


Output Size > 320 * 240


Save File > Checkbox > ON 


Save File Type > MOV QuickTime > Compression > Sorenson Video 3 > Quality > High
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Challenge

You’ve just created the Path for the conveyor belt on the XZ plane of the Front viewport. Your challenge is to create a new, more complex conveyor belt in the TOP viewport (XY plane). Using the Shape tools, create a conveyor belt system similar to the one in the diagram below. 

Remember what you have learned during this tutorial for Modifying Shapes– especially Fillet and Weld. You will also need to use [image: image37.png]Refine.




, which allows you to insert new vertices into the Shape (spline). Don’t be afraid to modify the height (Z) of the vertices so that the path of the conveyor belt moves up and down. 


Save your MAX file as conveyor_belt02.max and open the earlier saved version of this tutorial : conveyor_belt01.max

Good luck…!! 
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Note : The image above is for your reference only.
chris.shaw@mrboxes.com
Page 24
animated conveyor belt


